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Chapter 1: RF System QuickStart Guide
This QuickStart Guide is intended to help you get started using the RF System
Design Guide effectively. For detailed reference information, refer to Chapter 2, RF
System DesignGuide Reference/

The RF System DesignGuide has many simulation set-ups and data displays that are
very useful for designing a communication system. The simulation setups are
categorized by the System configuration, simulation technique, and type of topology.
This DesignGuide is not a complete solution for all types of measurements and
topologies, but covers the most common approaches. Subsequent releases of this
DesignGuide will include an expanded range of features.

Note This manual is written describing and showing access through the cascading
menu preference. If you are running the program through the selection dialog box
method, the appearance and interface will be slightly different.

Using DesignGuides
All DesignGuides can be accessed in the Schematic window through either cascading
menus or dialog boxes. You can configure your preferred method in the Advanced
Design System Main window. Select the DesignGuide menu.

The commands in this menu are as follows:

DesignGuide Studio Documentation > Developer Studio Documentation is only available
on this menu if you have installed the DesignGuide Developer Studio. It brings up
the DesignGuide Developer Studio documentation. Another way to access the
Developer Studio documentation is by selecting Help > Topics and Index >
DesignGuides > DesignGuide Developer Studio (from any ADS program window).

DesignGuide Developer Studio  > Start DesignGuide Studio  is only available on this
menu if you have installed the DesignGuide Developer Studio. It launches the initial
Developer Studio dialog box.

Add DesignGuide  brings up a directory browser in which you can add a DesignGuide
to your installation. This is primarily intended for use with DesignGuides that are
custom-built through the Developer Studio.
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RF System QuickStart Guide
List/Remove DesignGuide  brings up a list of your installed DesignGuides. Select any
that you would like to uninstall and choose the Remove button.

Preferences brings up a dialog box that allows you to:

• Disable the DesignGuide menu commands (all except Preferences) in the Main
window by unchecking this box. In the Schematic and Layout windows, the
complete DesignGuide menu and all of its commands will be removed if this box
is unchecked.

• Select your preferred interface method (cascading menus vs. dialog boxes).

Close and restart the program for your preference changes to take effect.

Note On PC systems, Windows resource issues might limit the use of cascading
menus. When multiple windows are open, your system could become destabilized.
Thus the dialog box menu style might be best for these situations.
1-2 Using DesignGuides



Accessing the Documentation

To access the documentation for the DesignGuide, select either of the following:

• DesignGuide  > RF System > RF System DesignGuide Documentation (from ADS
Schematic window)

• Help > Topics and Index  > DesignGuides > RF System (from any ADS program
window)

Basic Procedures
The features and content of the RF System DesignGuide are accessible from the
DesignGuide menu found in the ADS Schematic window.
Basic Procedures 1-3
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Transmitter/Receiver Design
Using a dialog box labeled Transmitter/Receiver Design on the menu, you select your
desired communication configuration, as shown here.The first step is to select one of
the two available system configurations from the RF System tab of the dialogue box.

Having identified the type of communication system, you then select one of the nine
simulations available from the Simulation tab, as shown in the illustration that
follows. The simulations include

• Source Modulation (you choose the type of modulation on the next tab)

• Noise Figure (Tabular Format)
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• Carrier to Noise Ratio (Tabular Format)

• Carrier to Intermodulation Distortion (Tabular Format)

• Spurious Response (Table and Graph)

• Spurious Response as a function of the LO frequency (Table and Graph)

• S Parameters (Graphical Format)

• Gain Compression (Graphical Format)

• Carrier to Intermodulation Distortion with swept RF input power (Graphical
Format)
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Having selected Source Modulation on the previous tab, you then have a choice of
modulations. If you have developed your own source modulation, you can replace the
source on the schematic. The Not Applicable box will be highlighted if you have not
chosen source modulation on the previous tab.

The selection box for source modulations is shown here.
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Shown here is the selection box for system topology. The grayed-out selections are not
available with the previous tab selections. Click one of the available selections. For a
detailed description of the topology selections, refer to the RF System DesignGuide
user manual. If the communication system is a transmitter, you have a choice of 6
topologies. If the communication system is a receiver, then you have a choice of 2
topologies. The topologies are functions of whether the upper sideband or lower
sideband is used for each mixer.
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Transmitter/Receiver Topologies
The first step in most system designs is to select a topology. Typically a receiver uses
either one or two stages of frequency conversion. Most receiver systems use the lower
sideband of the mixer output at each frequency translation and therefore there are
only two topologies. Whereas, for transmitters, the configurations are more varied,
this DesignGuide has topologies for each of the four double stage up converters, as
well as the two possible single stage up converters. There is a Transmitter example
included to demonstrate how the pre-defined topology can be modified to your
configuration

From the Schematic window, select DesignGuide > RF System Design Guide >
Transmitter/Receiver Topologies.

.

1-8 Transmitter/Receiver Topologies



Co-Simulation Topologies
To use the system topology within a Ptolemy simulation, there are co-simulation
topology modules to facilitate the process. The topology that has been designed and
tested with the Type of Measurement schematics can then be entered into these
modules for further testing in the Ptolemy environment.

From the Schematic window, select DesignGuide > RF System Design Guide >
Co-Simulation Topologies.

.
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Communication Examples
Some example files show how the co-simulation modules are inserted into the
Ptolemy schematics. From the Schematic window, select DesignGuide > RF System
DesignGuide > Comunication Examples.

.

Display Simulation Results
The Display Simulation results menu selection is only present as a means of opening
secondary data displays that correspond to a particular schematic. Most of the
simulations with modulated signals have a second data display that shows the
spectrum, power, and ACPR calculations. This secondary data display can only be
opened via this menu selection. However, if you rename the schematic, the menu
selection will not work anymore. For this reason, we recommend that you open the
corresponding data display before renaming a schematic. After renaming schematics,
you must open data displays using one of the standard ADS methods.
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Chapter 2: RF System DesignGuide
Reference
The RF System DesignGuide is integrated into Agilent EEsof ’s Advanced Design
System environment, working as an interactive handbook for the creation of useful
designs. The Guide contains many templates to be used in the ADS software
environment. These templates can assist the system developer in designing a
transmitter/receiver to meet performance specifications.

You can use the Transmitter/Receiver Topologies templates to define a system
configuration, then proceed to characterize the performance with respect to
quantities such as Noise Figure, Carrier-to-Noise Ratio, Carrier-to-Intermodulation
Distortion, etc. The final performance measurement is then observed as the given
modulation is applied and quantities such as ACPR and EVM are measured. If more
sophisticated sources are required, the Co-Simulation Topologies can be used to
easily interface with either a user-defined Ptolemy source or one of the available
libraries. The DesignGuide provides a complete tool kit to interactively explore
Transmitter/Receiver systems at the top level as part of an integrated design process.

In addition to the requirements of theAgilent EEsof ADS software, the RF System
DesignGuide requires approximately 60 MBytes of additional storage space.

Note This manual assumes that you are familiar with all of the basic ADS program
operations. For additional information, refer to the ADS User’s Guide. For access to
the complete set of ADS online documents, select Help >Topics and Index from an
ADS program window.
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Using the RF System DesignGuide
The key features of the RF System DesignGuide follow.

• Predefined system characterization templates and data displays:

• Noise Figure

• Carrier to Noise Ratio

• Carrier to Intermodulation Distortion

• Spurious Response

• Spurious Response as a function of the LO frequency

• S Parameters

• Gain Compression

• Carrier to Intermodulation Distortion with swept RF input power

Predefined templates and data displays for various modulation sources:

• pi/4 DQPSK

• QPSK

• 16 QAM, 64 QAM, 256 QAM

• IS95 and CDMA2000 (reverse and forward link)

• Co-Simulation Links to Ptolemy Libraries

• GSM, OFDM and BlueTooth Ptolemy examples

• Predefined Transmitter and Receiver Topologies:

• Single Stage Down Converter (mixer LSB)

• Double Stage Down Converter (mixer #1 LSB, mixer #2 LSB)

• Single Stage Up Converter (mixer LSB)

• Single Stage Up Converter (mixer USB)

• Double Stage Up Converter (mixer #1 LSB, mixer #2 LSB)

• Double Stage Up Converter (mixer #1 LSB, mixer #2 USB)

• Double Stage Up Converter (mixer #1 USB, mixer #2 LSB)

• Double Stage Up Converter (mixer #1 USB, mixer #2 USB)
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• Co-Simulation Topologies:

• Single Stage Down Converter (mixer LSB)

• Double Stage Down Converter (mixer #1 LSB, mixer #2 LSB)

• Single Stage Up Converter (mixer LSB)

• Single Stage Up Converter (mixer USB)

• Double Stage Up Converter (mixer #1 LSB, mixer #2 LSB)

• Double Stage Up Converter (mixer #1 LSB, mixer #2 USB)

• Double Stage Up Converter (mixer #1 USB, mixer #2 LSB)

• Double Stage Up Converter (mixer #1 USB, mixer #2 USB)

• Communication Examples:

• 16 QAM complete with Transmitter, Receiver and LOS Link

• GSM complete with Transmitter, Receiver and LOS Link and co-simulator

• BlueTooth Ptolemy example with Receiver and co-simulator

• GSM Ptolemy example with Receiver and co-simulator

• OFDM Ptolemy example with Receiver and co-simulator

Transmitter/Receiver Design
The general design flow for a transmitter or receiver consists of a three-step process
before a prototype is developed. The first step is the creation of the frequency
converter topology; this is followed by performing system measurements to ensure
that the specifications can be met. The system tests usually involve Carrier to Noise
Ratio, Carrier to Intermodulation, Noise Figure, Spurious Response, and others. This
initiates an iterative process between the choice of system architecture and the
system measurements. Once a candidate design has been optimized, measurements
can be performed using the required signal modulation. These tests may involve
Adjacent Channel Power Ratio, Error Vector Magnitude, Peak to Average ratio and
others.

The system designer identifies a candidate topology from which he then proceeds to
define the individual component specifications. Many designers focus initially on the
mixers and filter requirements. The mixers can play a significant role in setting the
system Dynamic range and reducing costs. Minimizing the number of components at
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the higher frequencies will typically reduce the system costs. Filters are placed at
strategic points in the line-up to eliminate spurious signals and control the CNR.
Attention is given to the filters to ensure that their individual order is not excessive,
which would increase the loss and size. The gain stages can then be placed
throughout the receiver to minimize the system Noise Figure (increase sensitivity)
and maintain a good CNR throughout the chain. As one gets closer to a candidate
topology, the individual component specifications can be filled out. This is an iterative
process in which the system designer converges on a suitable transmitter/receiver
design that meets all his criteria.

Having pre-configured topologies that can be readily modified to user configurations
will aid the designer. Nodes and probe components are identified to facilitate the
measurement process. The topologies all have assigned node and probe names that
need to be maintained for the simulation to work properly. The nodes and probe
names can be placed at various points along the chain, but all names must be
included. (Be careful with the syntax). The more advanced user can alter the names
as well as add additional names but the schematics as well as the data displays will
need to be modified.
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After a suitable review, the system designer then passes the individual component
specifications on to the component designers. The component designers then proceed
to develop a CAD representation of the individual components. These designs can be
inserted in place of the system level building blocks to investigate their overall
impact on the performance. This allows the assembly of a complete CAD
transmitter/receiver design, which can be further tested.

The designed transmitter/receiver performance then needs to be evaluated.
Pre-configured schematics and data displays that you can readily modify for your
system will speed up the design process. Replace the place-holder with your
candidate transmitter or receiver design. The pre-configured schematics are
constructed for a particular system measurement. Then edit the schematic
parameters and parameter sweep ranges to reflect the desired system. Schematic
equations are included to aid the extraction of key measurements such as power,
noise, spurious levels, gain, ripple, etc.

Various schematic controllers are used wherever appropriate to reduce the
simulation time. Some Schematic Controllers have sweep variables that allow you to
observe the sensitivity to various parameters. The Schematic Parameters are central
to the design. The Frequencies and Powers of the various sources are typical. These
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parameters need to be adjusted for your design. The user-designed
transmitter/receiver topology needs to be inserted in place of the existing preassigned
topology (Insert User Configuration). The Schematic Equations are used to extract
measurements pertinent to the simulation.
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An example of an important measurement is the carrier to noise ratio. The noise
limitations may arise from the noise floor of the individual components or it could be
from the excessive phase noise of the local oscillators. You also have the flexibility of
entering an input noise source.
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There are two factors that limit the transceiver system dynamic range:

• Carrier-to-Noise Floor Ratio

• Carrier-to- Intermodulation Level

The C/IMD performance is limited by the third order intercept point (TOI) of the
individual components. The TOI at various nodes in the chain can be estimated as a
function of the power levels of the fundamental and intermodulation signals. Or the
actual C/IMD levels can be plotted as a function of the input power level. This is a
useful means for determining the dynamic range limiting components.
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The introduction of nonlinear components into the transmitter/receiver generates
unwanted spurious signals that need to be controlled. Spurious signals that fall
in-band will degrade the BER performance for the given channel. Spurs that fall
out-of-band may contaminate other channels or they may be aliased into the given
channel. The data display below is useful for identifying the levels of the various
spurs as well as assisting in tracking the component from which they originate. The
data display can have variable parameters such as the RF input frequency, power
levels, LO frequencies, etc. This can aid in the optimization of the system chain.
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Once a candidate design has been developed and has been tested against the
standard system level specifications, you can introduce a modulated source. The
modulated signal can either be created using the Analog/RF components or in
Ptolemy, with a co-simulation used to translate between Ptolemy and the Analog/RF
transmitter or receiver.

Applying the modulated source to the transmitter/receiver will allow for more
fundamental measurements such as BER,EVM, Average Power Output, Peak to
Average Ratio, ACPR, etc. The testing based on a two tone (3dB Peak/Average Ratio)
will not give the appropriate measurement of the ACPR when, for example, a CDMA
signal is applied. The BER measurement can take a significant amount of time to
simulate. Therefore, a measurement of the Error Vector Magnitude can serve as an
intermediate evaluation of the performance of the system. The ultimate goal would
be to run a Ptolemy simulation for a long enough period of time to evaluate the BER.
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The Error Vector Magnitude measurement would provide you with an initial
indication of the performance achievable by the transmitter/receiver. The
constellation diagrams help in giving insight into the contribution of the distortion.
As an example, if compression and phase rotation were observed on the constellation,
this could be traced back to the overdriving of a particular stage in the chain.
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Transmitter/Receiver Topologies
There are 8 predefined topologies that have corresponding measurement Schematics
and Data Displays. They are listed below:

• Single Stage Down Converter (mixer LSB)

• Double Stage Down Converter (mixer #1 LSB, mixer #2 LSB)

• Single Stage Up Converter (mixer LSB)

• Single Stage Up Converter (mixer USB)

• Double Stage Up Converter (mixer #1 LSB, mixer #2 LSB)

• Double Stage Up Converter (mixer #1 LSB, mixer #2 USB)

• Double Stage Up Converter (mixer #1 USB, mixer #2 LSB)

• Double Stage Up Converter (mixer #1 USB, mixer #2 USB)

You would select one of the given topologies, then proceed to modify it for your system
requirements. The components in the schematic are just placeholders and you can
replace, add, or expand on the given configurations. The important elements are the
node and probe names and the frequency conversion of the mixers (ie whether it is
LSB or USB). The identification of the LSB (lower sideband) or USB (upper sideband)
is important for insuring that the simulation and data displays will give the correct
results.
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Co-Simulation Topologies
Ultimately, you would like to integrate the transmitter or receiver with the DSP
portion of the communication system. Ptolemy can be used to generate a wide variety
of baseband modulation signals. This allows you to perform more extensive tests on
the system. The designed transmitter/receiver can then be integrated into Ptolemy
using the co-simulator, allowing efficient translation between the DSP world and the
Analog/RF world.

This figure shows a template for integrating your receiver design into the Ptolemy
simulation. Again, the user-defined parameters would be inserted into the schematic.
Notice that the envelope simulator has been used.
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An example of the insertion of the receiver schematic template from the one created
appears in the preceding figure. Also we have added the co-simulation block for
translation from Analog/RF to Ptolemy.
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Communication Examples
The transmitter/receiver design dialog box assists you in creating up and down
converters. The example below shows how the designed Transmitter and Receiver
can be used in a communication system. This example uses a Line-of-Sight Link
where the antenna gains, vswrs, distance, etcetera can be specified. The example is
simulated in the Analog/RF environment using a 16 QAM source.
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Another example of a GSM communication system is shown here. The transmitter
and receiver were created using the Transmitter/Receiver Design dialog box. These
topologies were then inserted into a schematic set up for simulation, along with the
identified channel and are identified via the up and down converter symbol. The
schematic set up for simulation was then placed in the Ptolemy environment along
with the GSM modulator and demodulator for a complete DSP to Analog/RF to DSP
simulation.
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